Firefox 1.5.0.1 officially released

Firefox just got updated to 1.5.0.1. If you haven’t gotten Firefox 1.5, I think it’s safe enough now. If you’re not sure how to update to 1.5.0.1, the picture below should help. (Note: You need to be running 1.5 in order to update this way. If you’re running an older version, you need to get the full installer.)

How to update Firefox 1.5

(via Digg)

Published by

Bryan Villarin

Bryan is a Trust & Safety Wrangler at Automattic. He's also a photographer, card magician, and cat whisperer. (Thanks to my friend and colleague Steve Blythe for the sweet photo!)

2 thoughts on “Firefox 1.5.0.1 officially released”

  1. I tried the 1.5 version of FF and to be honest it messed up my machine. XP pro. Half my plugins would not work. Not just my machine but the same result on the other two I have here. So reverted back to 1.0.7. I wonder if 1.5.1 will be any different..I shall see.

    Like

  2. If the plugins are incompatible with the newer versions, let the plugin developer know you want them to work…if it’s the plugins you really need. I don’t use too many, but the ones I do use are the more popular ones.

    Like

Leave a Reply to joss Cancel reply

Please log in using one of these methods to post your comment:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s